UI Model: Data Tab

Once you enter the UI Models, you are redirected to the Model Overview Menu, where all the created models are listed, as well as all the necessary information to immediately attest to what you are going to do next.

Once you enter a particular model, by default you are entering the Overview tab. After you have set up a structure, meaning that we now have an output table from our model, you can view the result of the output table in the Data tab. Let's now introduce this section by all its elements:

19141914

Note: If the data section is not visible, you probably need to click the expand button.

1 - Expand / Minimize Button. This button helps in making the board higher by hiding the model section panel. Once you finish with the working board you might need to show the panel again so you jump between sections.

2 - Data Section. In this section your data result set table/s will appear. This means that your output node/s have been committed at least 1 time, and now it is ready to be used as integration for further actions.

3 - Model information. From this section you might as well change the model name, make it a favorite, or add/change a description by hovering over the information icon.

You might also see version changes by clicking the git icon. There is necessary information on the commits in history, as well as details about changes: who made changes and what was changed. You can revert the changes anytime as in any previous version!

309309 15331533

4 - Table Overview Section. In this vertical section all the tables will appear. You need to click on a table to view it's data in a tabular form.

366366

At the top of the Table section you can see the following:

  • Total number of tables → Displays the total number of output tables you have committed at least once.
  • Sort → Action to sort tables by name, status, and number of rows.
162162
  • Filter → Function to search for the table name you are interested in. The table that matches your filtering criteria will display on the top.
360360

5 - Single Table. You need to click on a single table to view its data in a tabular form (as displayed in counter 6). Each table will display the following information and actions:

  • Table name
  • Job Id
  • Information section. You can add/change a description when you hover on the information icon.
  • Status: Ready/Pending/Failed.
  • Total rows. The total number of rows this single table has. Note: The number shown is rounded.
    Redirect to BigQuery. Once you click the link you will be brought to the BigQuery table.
414414

6 - Data board. Once you click a single table, the data will appear on the right in a tabular form. This data should be the same as your last committed output of this table in the output node. Within the dataset you can perform analytics by right-clicking cells inside the data board.

The following options are available:

  • Copy→ Copies the single-cell text you right-clicked into.
  • Autosize all columns→ Expands the columns horizontally so the text inside cells is easily visible.
  • Export in CSV or Excel → Exports the table into CSV or Excel into your local computer. Important Note: This action will only export the preview of your dataset, not all the columns. In order to export all the rows, you would need to scroll down until the preview reaches the total number of rows. By default Y42 previews only the first 100 Rows.
  • Chart Range → It will display the data set in your chosen chart. You need to select the area that will serve as a data source for your chart and then right-click inside the chosen area. You might choose a variety of chart types to preview selected values.
  • Analyze value as JSON→ Outputs the data of the JSON in a formatted form:
662662

7 - Columns. By clicking the columns we have the possibility to group the data by column. You can also remove the columns you do not need, this way your data are cleaner for your analysis.

After you click the column button all the columns will display in a menu bar on the right. if you want to group by the data drag the column you wish into Row Groups (do so by clicking the two horizontal lines near the column name).

8 - Filters. When clicking the filters button all the columns will display in a menu bar on the right. You might want to filter the column data, without needing to scroll horizontally (when you have too many columns) to find the column you need to filter out. That is when the vertical column listing comes to the rescue.

Simply click on the column you need to add filtering criteria and add the condition.

9 - General statistical data. This area pr in the bottom of the table, provides information on:

  • Preview Rows/ Total Rows
  • Number of Columns
  • Selected cells → displays the total number of the selected cell you have made
  • Size
  • Data View / Column View → By default it is Data View, where all the data appear. If you click "Column View" then only the columns will appear, without the data.

More on Data Preview features

With the data preview features, you can easily visualize and quickly validate data while modeling. This makes it easier to understand each step of your analysis and to pick up basic errors that could cause issues later on.

Watch the following video for a more comprehensive overview on how to use the data preview features:

In the modeling space, when clicking on a node, you can preview input as well as output data. The bottom section, shows some basic data about your table:

  • Total number of rows
  • Total number of columns
  • Sum, Average, and Count of the values for a set of numeric values selected

On the right side, you can find the full list of columns in your table and also select only some of them. Furthermore, you can apply filters your data preview.

The icons in the header of each column allow you to carry out additional actions:

  • Visualize basic descriptive statistics by clicking on the blue icon appearing when hovering over the section
  • Sort data in ascending order with the first click, and in descending order with a second one
  • Group data by a column similar to the Pivot table
  • Pin a column to the left or to the right

Furthermore, you can create a quick chart displaying the values of selected cells by right-clicking on your selection.